CHAPTER 8

Creating Reports with InfoMaker

About this chapter

Contents

Reports display and summarize data. You can view reports on the screen and

print reports on the printer.

In this tutorial you will create a report using the data in the contact table. The
report you create groups contacts by job role and lists phone and fax numbers

for each contact.
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How long will this tutorial take?
About 45 minutes.
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Creating the basic report

Creating the basic report

Now you will create the basic report. To do this you select a report style and
the data to be used for the report.

1 Click the Report painter button in the PowerBar.
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The Select Report dialog box displays. It lists reports in the current
library (TUTOR_IM) and has a New button for creating new reports.
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2 Click New.

The New Report dialog box displays. It contains the data sources and the
report styles you can choose.
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Chapter 8 Creating Reports with InfoMaker

About data sources
Quick Select is for simply choosing columns and specifying
selection criteria and sorting, which is what you want for this tutorial.

SQL Select is for using other SQL options not available with Quick
Select.

Query is for specifying the name of a query that describes the data
source. You define a query in the Query painter.

External is for specifying data that comes from a source other than a
database.

Stored Procedure is for specifying data using a stored procedure.

About report presentation styles
A report presentation style is a predefined way of presenting
information in a report.

3 Click the Quick Select data source and the Tabular presentation style.
Make sure the Preview when built checkbox is not selected and click OK.

The Quick Select dialog box displays. In this dialog box you select the
table to use and the columns you want included in the report.
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4  Click contact.
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Creating the basic report

The contact table's columns display. For this report you will select five.
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5  Click last_name, first_name, and title.
Use the scrollbar to scroll the list of columns.
Click phone and fax.

InfoMaker moves the selected columns to the grid at the bottom. You
can use this grid for reordering columns and for providing sort and
selection criteria. For this report you do not need selection criteria, and
you will specify sorting later.
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Chapter 8 Creating Reports with InfoMaker

Quick Select E
1. Click on table(s] to select or deselect. Ta display comments far a 0K |
2 Select one or more columng. table or column, click
3. [Optional] Enter sarting and the right mouse button, C |

zelection critenia belaw, anee
Add All
Tables: Columns: __l
Help |
Comments:
Fax Mumber of the contact
Calumr: Last Mame First Mame Title -
Sort:
Criteria:
ar: -
1| | 3
Click OK.

A design version of your report displays in the Report painter
workspace. It uses the columns and report style you selected.
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Creating the basic report

The text for the column headers comes from the repository. The names
of the columns appear where the data values will be displayed.

The repository

The repository stores information about data such as labels and
display formats. When you create forms and reports, InfoMaker uses
repository information to create the basic report or form.

You put information into the repository using the Database painter.
For example, in the Table tutorial of InfoMaker's Getting Started
manual, you define the label Job Role: for the title column. Then
when you use the title column in a form or report, InfoMaker uses the
label Job Role:.
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Chapter 8 Creating Reports with InfoMaker

Previewing the report

In this section you will preview your report to see what it will look like when
you print it. Usually you preview your report when you make changes that
affect the way it looks.

1 Select Design> Preview from the menu bar.

The report displays. Notice that it includes the header information for
the report and information from the database.
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InfoMaker retrieves information for all contacts and displays as many as
will fit on the screen.

If some of your columns are displaying too close together, ignore it for
now. We will fix the spacing of the columns later on in the tutorial.

2 Use the scrollbar on the right side of the window to see more data.
3 Click the Preview button in the PainterBar.

You return to the Report painter workspace.
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Saving the report

Saving the report

Now you will save the report and give it a name.
1 Make sure you are back in the workspace (if not, click Preview).
Select File> Save from the menu bar.

The Save Report dialog box displays, with the pointer positioned for you
to type a name for the report.

2 Type contacts_by_jobrole.

3 Click in the Comments box and type This report shows my contacts

grouped by job role.
Save Report

Eeports:
Liep K

Icontacls_by_iobrnle

a_read_me_first Cancel
attrib_hirthdays
attrib_crogzout_and_wizible
attrib_eszcapernent_ratation
attrib_font_height

attrib_format LI
=
[ -

2l

Help

Camments:

Thiz report shows my contacts grouped by
job role.

4  Press the ENTER key.

InfoMaker saves your report.
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Chapter 8 Creating Reports with InfoMaker

Setting up the design environment

In this section, you set up the design environment to make it easier to work.
You will:

¢ Show the edges of objects
¢ Display the grid and ruler

Object edges show how big the objects are. By displaying object edges, you
can easily check for overlapping and make sure the spacing around objects is
what you want. Displayed edges are a design aid only; they do not appear in
the report.

The InfoMaker grid and ruler help you align objects.

1 Select Design> Options from the menu bar.
The Report Options property sheet displays.

2 Make sure the Show Grid option, Show Ruler option, and the Show Edges
option are selected.

Make sure Snap to Grid is not selected.
Click OK.

Report Options E3

General | Zoom | Generation |

Alignment Grid

[~ Snhap ta Grd ®: Ig_
¥ Show Grid v: [8
[¥ Shaws Buler

[~ Preview on New
[+ Retain Data to Design

[+ Retrieve on Preview

QK. I Cancel Apply Help
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Setting up the design environment

The workspace shows a dotted grid and a ruler. Text and columns show
edges.
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Chapter 8 Creating Reports with InfoMaker

Defining sorting and grouping

2

Now you will specify sorting and grouping. You want the report to group
contacts by title. This means you need to sort by title and then specify

grouping by title.
1

Select Rows> Sort from the menu bar.
The Specify Sort Columns dialog box displays.
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Move the pointer to the word title in the Source Data box and drag it to

the Columns box.

(To drag, press and hold the left mouse button, move the mouse, then

release the mouse button.)
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Ascending and Descending

Ascending and descending are options for sorting. Since you are

alphabetizing in this tutorial, you want to sort in ascending (from A
to Z) order. Ascending is the default, so you do not have to do

anything.
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Defining sorting and grouping

You've specified the sorting required to group on title.

Next you will specify sorting by last name and then by first name. This
ensures that your contacts are alphabetized within each group.

3 Drag last_name and first_name to the Columns box.

4 Click OK.

The sorting definition is complete. You return to the Report painter
workspace.

5 Select Rows> Create Group from the menu bar.

The Band Object property sheet displays. You are going to group on the
title column. All contacts with the same title will be grouped together.

6  Drag title to the Columns box and click OK.
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Chapter 8 Creating Reports with InfoMaker

The grouping definition is completed. You return to the Report painter
workspace.
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You have two new bands for the group in the report. You'll learn about
bands in the next section.

Select Design> Preview from the menu bar.

You see the report and its data. Notice that the data is sorted. You do not
see the groups yet. In a few minutes, you will make some changes so the
groups will appear.
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Click the Preview button.

You return to the Report painter workspace.
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Enhancing the report

Enhancing the report

You can enhance reports in many ways. In this section you will:
¢ Rearrange objects

¢ Add atitle and date

¢ Add page numbers
L4

Add a count of the total number of contacts

Rearrange objects

To rearrange objects, you will:
¢ Put the job role into the group header and change its display font

¢ Move the remaining columns to close the gap left by moving the column

This is what the workspace will look like when you have finished
rearranging the objects.
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Chapter 8 Creating Reports with InfoMaker

About report bands
The design version of the report that you see in the workspace divides the
report into bands of information.

The header band contains heading information and is located at the top
of each page.

The detail band contains the retrieved data.

The summary band contains summary information that applies to the
entire report and is located at the end of the report.

The footer band contains information to be located at the bottom of every
page, such as a page number.

For groups, the group header band and group trailer band contain
information for the group.

1 Move the pointer to the gray bar entitled 1: Header group title until you
see a double-pointed arrow.
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2 Drag the band down about 4 to 6 grid dots.

(To drag, press and hold the left mouse button, move the mouse, then
release the mouse button.)

=] Report - contacts_by jobrole

_|I|||I|1||I|||I|2||I|||I|3|I|||I|4||I|
----- LastMame. - - - - | ... FirstHame. . . .. [. . ... JobRole - - - .
Header t
1: Header group title t

Jast name . |fiist_nama ----------- titla ---------------

Detail 1
1: Trailer group title t+

Summary t
Footer t
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Enhancing the report

3 Move the pointer to the title column and drag it into the band for the
group header.

Put it near the bottom of the band as shown.

Bl Report - contacts_by_jobrole

_|I|||I|1||I|||I|2||I|||I|3|I|||I|4||I|
..... Lagtuame.....|.....|=ir,51“ame..... .. ... JobRole .. . ..

_ | Header t

oo Ll
J e Lo

__|1: Header group title 1

Alast_narme - ... |fi;st_nama ........... I .................
Detail +

1: Trailer group title t

Summary t
Footer 1

4 With the title column still selected, click B for bold and [ for italic on the
StyleBar.

=] Report - contacts_by jobrole

|I|||I|1||I|||I|2||I|||I|3|I|||I|4||I|

----- LastMame. - - - - | ... FirstHame. . . .. [. . ... JobRole - - - .
Header t

: """""""" B
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1: Header group title t

Jast name . |fiist_nama ----------- | -----------------
Detail 1

1: Trailer group title t+
Summary t
Footer ¢

This makes the job role (title) stand out in the report.
5 Select Design> Preview from the menu bar.

You see the report and its data.

148



Chapter 8 Creating Reports with InfoMaker
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Notice that the value of the title column appears only once for each
group. This is because the title column is now located in the group
header band.

Previewing is helpful for identifying problems. Notice that the header
Job Role is still present even though there is no longer a column in the
detail band. When you return to the workspace you will delete the text.

6  Click the Preview button to return to the workspace.
Click the text Job Role in the header field.

7  Press the DELETE key.
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Enhancing the report

150

10

Drag the First Name and Last Name textboxes in the header band to the
right to fill the empty space.
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Drag the first_name and last_name columns in the detail band to the
right to fill the empty space.

If when previewing your report, your phone and fax numbers do not
have enough room to display, lengthen the fields now. Click on fax and
move your cursor to the edge of the field until you see a double arrow.
Drag the arrow until the box is large enough to hold the resulting data.
Perform the same procedure on the phone field. You may have to move

a few of the fields in order to make room to expand the phone and fax
fields.
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Chapter 8 Creating Reports with InfoMaker

You will make one final visual improvement now by left aligning the
text in the column headers.

11 Choose Edit> Select> Select Text from the menu bar.

This selects all the headers. It may be difficult to see that they are
selected because the band is so narrow.

12 Click the left alignment button on the StyleBar.
If your headers are not already bold, click the Bold button.
All the headers become left aligned (and bold).

T Ty e ™

13 Select Design> Preview from the menu bar.
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14 Click the Preview button to return to the workspace.

Add a title and date

Now you will add a title and date to the header band. They will be at the top
of each page.
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Enhancing the report

1 Move the pointer to the gray bar marked Header and drag it down about
10 grid dots.

o

2 Choose Edit> Select> Select Text from the menu bar (or use lasso
selection).

This selects all the headers.

3 Press the DOWN ARROW key to move all the headers down close to the gray
band.

This leaves room for the title.

4 Click the Text button in the Objects dropdown toolbar in the PainterBar
(or select Objects »Text. from the menu bar).

Move the point of the pointer above the First Name box and down one
grid dot from the top of the page.

Click.
This positions the text box for the title.
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Chapter 8 Creating Reports with InfoMaker

5

Type My Contacts.
Select 14 from the font size dropdown listbox to make the title bigger.
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6  Click the Today button in the Objects dropdown toolbar.

Move the point of the pointer to the upper-left corner.

Click.
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Enhancing the report

This places a computed field in the report. The computed field is for

today's date.
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7  Select Design> Preview from the menu bar.

Your report now has a title and today's date.
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8  Click the Preview button to return to the workspace.

Add page numbers

Now you will put page numbers in the footer band.

1 Move the pointer to the gray bar marked Footer and drag it down about

4 ¢grid dots.

If necessary, use the scrollbar to make room at the bottom of the design

workspace.
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Chapter 8 Creating Reports with InfoMaker

This makes space for the page number, which will be another computed
field.

Click the Page button in the Objects dropdown toolbar.

In the footer band, move the point of the pointer to the center and down
2 grid dots.

Click.
Select a different font size (10) from the style bar.

This places a computed field for page numbers.
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Select Design> Preview from the menu bar.
Click the scrollbar until you move to the bottom of the page.

You now have a page number on your report.
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Enhancing the report
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4 Click the Preview button to return to the workspace.
Add a count of the total number of contacts

Now you will add a count of the total number of contacts you have to the end
of the report. You will put the information in the Summary band, which
means it will print at the end of the report.

Like the date and page number, the count will be a computed field. Only this
time, you will create it yourself using the Compute button.

1 Move the pointer to the gray strip marked Summary for the summary
band and drag it down about 6 grid dots.

This makes space for the total number of contacts, which will be a
computed field.
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2 Click the Compute button in the Objects dropdown toolbar.
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Chapter 8 Creating Reports with InfoMaker

In the summary band, move the point of the pointer to the center and
down 4 grid dots.

Click.
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This sets the position for a computed field that you will use for the total
number of contacts. The Computed Object property sheet displays.

3 Inthe Name box, type total_contacts.
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4 Click the More button.
The Modify Expression dialog box displays.

5 In the Functions box, click count(#x for all).
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Enhancing the report

6

7

158

Your dialog box should look like this. The placeholder for what to count
is highlighted.
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In the Columns box, click last_name.

This selects the last name column to apply the count function to. You

are going to count all the last names to find out how many contacts you
have in the report.
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Click Verify.

You should get the message box stating that your expression is valid.




Chapter 8 Creating Reports with InfoMaker

10

Click OK to close the message box.

Click OK to complete the definition of the expression for the computed
field.

Click OK to accept the name and expression and close the property
sheet.

You return to the workspace. The computed field is in place.

couny B
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Click the Text button in the Objects dropdown toolbar.
Position the pointer to the right of the computed field and click.
Type contacts in all.

Drag the text box to line it up with the computed field.

coumt] 1| contacts in dl

Pane *+ panef) +  of "« pageCasaty

Select the computed field and the text using lasso selection.

On the StyleBar, select 10 for a font size and click / for italic and B for
bold.

How to use lasso selection

Position the pointer, press and hold the left mouse button, and drag
the lasso around everything you want to select. Then release the
mouse button.
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Enhancing the report

11 Select Design> Preview from the menu bar.

Press the PAGE DOWN key and use the scrollbar until you see the end of
your report.

The summary band of your report now shows the total number of
contacts in the report. The number you see may not be 61. The number
depends on the contacts currently in your database.
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12 Click the Preview button to return to the workspace.
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Chapter 8 Creating Reports with InfoMaker

Printing the report

1 Select Design> Preview from the menu bar.
Your report displays.

2 Select File> Print from the menu bar.
The Windows Print dialog box displays.

Frinter:  Fran'z printer [ HT= on \WPRINTFARME T oo

Page Range ﬂl
L] Frinter... |
" Cument Page e

' Fages I Ll
Enter page numbers and/or page ranges Frint ta Fil
separated by commas. For example, 2.5.8-10 ™ Print to Fie

¥ Collate Copies

Frint: I.-’-‘AII Fages in Range j

3 Click OK.
4 Click the Preview button to return to the workspace.
5  Select File> Close from the menu bar.

If you are prompted to save changes, click Yes.

This closes the Report painter. You return to the PowerBar.
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Printing the report
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